Selasa, 06 Desember 2011

Hari Keempat : Lab 8 BGP Confederation

konfigurasi pada iBGP peering adalah network x.x.x.x akan di advertise ke iBGP peering yang mempunyai peering ke eBGP atau iBGP lainnya


R1#sh run
Building configuration...

Current configuration : 1011 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
voice call carrier capacity active
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 14.14.14.1 255.255.255.0
 speed auto
 full-duplex
!
router bgp 12001
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 12
 bgp confederation peers 12002
 network 1.1.1.1 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 12002
 neighbor 14.14.14.4 remote-as 12001
 neighbor 14.14.14.4 next-hop-self
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
R1#
R2#sh run
Building configuration...

Current configuration : 1363 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
voice call carrier capacity active
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 25.25.25.2 255.255.255.0
 serial restart_delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart_delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart_delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart_delay 0
!
router rip
 network 2.0.0.0
 network 23.0.0.0
!
router bgp 12002
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 12
 bgp confederation peers 12001 12003
 network 2.2.2.2 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 12001
 neighbor 23.23.23.3 remote-as 12003
 neighbor 25.25.25.5 remote-as 12002
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
R2#


R3#sh run
Building configuration...

Current configuration : 1304 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
!
ip subnet-zero
!
!
no ip domain lookup
!
!
!
voice call carrier capacity active
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 36.36.36.3 255.255.255.0
 serial restart_delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart_delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart_delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart_delay 0
!
router rip
 network 3.0.0.0
 network 23.0.0.0
!
router bgp 12003
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 12
 bgp confederation peers 12002
 network 3.3.3.3 mask 255.255.255.255
 neighbor 23.23.23.2 remote-as 12002
 neighbor 36.36.36.6 remote-as 6
 no auto-summary
!
ip classless
no ip http server
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
R3#
R4#sh run
Building configuration...

Current configuration : 977 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 14.14.14.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 12001
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 12
 network 4.4.4.4 mask 255.255.255.255
 neighbor 14.14.14.1 remote-as 12001
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
R4#
R5#sh run
Building configuration...

Current configuration : 1111 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 36.36.36.3 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router bgp 12002
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 12
 network 5.5.5.5 mask 255.255.255.255
 neighbor 25.25.25.2 remote-as 12002
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end
R5#


R6#sh run
Building configuration...

Current configuration : 1064 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 36.36.36.6 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router bgp 6
 no synchronization
 bgp log-neighbor-changes
 network 6.6.6.6 mask 255.255.255.255
 neighbor 36.36.36.3 remote-as 12
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end
R6#




Tidak ada komentar:

Posting Komentar